PAT-Advanced 1001. A+B Format (20)

Calculate a + b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
#include <stdio.h>
#include <stdlib.h>
#define MAX 1000000

int main(int argc, char const *argv[]) {
int a = 0, b = 0, c = 0;
scanf("%d %d",&a,&b);
c = a + b;
if(c < 0){
c = -c;
printf("-");
}
if (c >= MAX) {
printf("%d,%03d,%03d\n",c/MAX,c/1000%1000,c%1000);
}else if(c >= 1000){
printf("%d,%03d\n",c/1000,c%1000);
}else{
printf("%d\n",c);
}
return 0;
}